Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 Program crashes on startup.... Help!!

View previous topic View next topic Go down 
AuthorMessage
Forts
Junior Member
Junior Member


Posts : 19
Join date : 2008-09-21

PostSubject: Program crashes on startup.... Help!!   Sun Oct 19, 2008 7:25 pm

I'm hoping someone can help me out here. I've been using Media Companion basically since it came out and absolutely love it. Here is my problem.... Windows went wonkly on my yesterday so I bit the bullet and decided to do a fresh install. Re-installed XP w/SP3, all my applications, drivers etc etc. I also installed the latest version of the .NET Framework and everything seems ok. However, when I try to launch Media Companion (latest build) the second the splash screen tries to pop up my computer locks up tight as can be. I've re-installed .NET with no difference. Does anyone have any suggestions as to what else I can try? Seeing as I don't get any error messages or anything I'm not sure where to look. I'm assuming it's a .NET issue but not sure where to go from here.

Any help would be greatly appreciated!
Back to top Go down
View user profile
Ryld
Junior Member
Junior Member


Posts : 23
Join date : 2008-10-12

PostSubject: Re: Program crashes on startup.... Help!!   Mon Oct 20, 2008 9:24 am

Dot net is a pain when it goes wrong, try installing another .net based application (Zscreen comes to mind, small and .net based)

if you have the same problem with that as well let me know, have some favourites on my laptop i'll boot it up and grab them.
Back to top Go down
View user profile
Forts
Junior Member
Junior Member


Posts : 19
Join date : 2008-09-21

PostSubject: Re: Program crashes on startup.... Help!!   Tue Oct 21, 2008 4:06 am

Hi, thanks for the tips! I tried ZScreen and it runs just fine. Are there any other dependencies that Media Companion could be calling that are causing the problems? (Not .NET related). I suppose I could try reverting back to an older version of .NET and see what that does.
Back to top Go down
View user profile
Ryld
Junior Member
Junior Member


Posts : 23
Join date : 2008-10-12

PostSubject: Re: Program crashes on startup.... Help!!   Tue Oct 21, 2008 8:45 am

There is a config.xml file placed into the directory the EXE runs, perhaps removing that might help the picture?

if this still doesnt provide any light, you maybe able to use process monitor from sysinternals to log the output of whats happening, so after a reboot the log file may have the answer as to what was happening at the time of your system lockup (perhaps trying to access something it doesnt like).


Another potential source of information would be your systems Event Viewer, found under Administrative Tools in the Control Panel. Specifically look at Application and System log, however on a freeze its quite probably it doesnt log the information (You could get lucky, I have in the past)
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Program crashes on startup.... Help!!   Tue Oct 21, 2008 12:19 pm

Media Companion has no dependencies except .net

It uses 2 dll files, one is merged with the .exe and another with the external medianfo.dll. Even if one is missing or corrupt then the program should run.

The worst that should happen is an unhandled exception. It definately sounds like the problem is with .net

All I can suggest is that you uninstall .net and download it fresh, from the microsoft website and then reinstall it.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
Forts
Junior Member
Junior Member


Posts : 19
Join date : 2008-09-21

PostSubject: Re: Program crashes on startup.... Help!!   Wed Oct 22, 2008 7:02 am

Well still no go. I uninstalled all the .net stuff on my machine, rebooted and re-installed .NET 3.0 (not 3.5). Still the same result. Hard crash as soon as the splash screen starts to draw. I removed the .xml file from the folder with no success. Not seeing much in the event logs either. Well, worse case I run media companion from another PC I guess.

Hmmm... wonder if it will run with the pc in safe mode? Gonna give that a try....

Edit: Success! Well, kinda. On a whim, before booting to safe mode I turned off my firewall (PCTools Firewall Plus) and low and behold the program started up just fine. So it's something in the application blocking park of the firewall it would seem.

Further followup: If you use the PCTools Firewall Plus, it's the 'Enhanced Security Verification' option that is causing the problems (it's located under Settings/Filtering). Unchecking this option lets XBMC Media Companion work just fine. I also found that CDBurner XP behaves the same (crashes on startup). It's also a .net based application. I have forwarded this info on to the folks behind PCTools Firewall and they are investigating.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Program crashes on startup.... Help!!   

Back to top Go down
 
Program crashes on startup.... Help!!
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: General Discussion-
Jump to: