Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 New Release Media Companion gen2 3.400

View previous topic View next topic Go down 
Go to page : 1, 2  Next
AuthorMessage
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: New Release Media Companion gen2 3.400   Sun Oct 10, 2010 9:56 pm

Changes for version 3.400

  • An updated IMDB scraper library has been included in this build that should hopefully fix the issues in yesterdays release.

  • An experimental file copy method has been added to the movie context menu, this may change in future builds.

  • Bugfix - Conversion from string "0000-00-00" to type 'Date' is not valid error when scraping certain tv shows.

  • Bugfix - Max Genre fields preference not saving

  • Bugfix - nfo files imported from XBMC only showed a single genre due to the different method of handling, the handling in MC is now the same as XBMC, although nfo files with the old single tag method can still be imported.

  • Bugfix - Exception not being raised when open folder context item fails.

  • Bugfix - Not handling none standard runtime figures fixed eg 'USA:100 min' - From this version of MC - the runtime tag in the main nfo body will be numerical, although 'mins' will still be added to the browser.

  • Bugfix - Using batch rescrape would remove media tags

  • Bugfix - Fixed exception when trying to unlock a tv show without a TVDB ID

  • Bugfix - Open file would not work for tv show special episodes

  • Bugfix - Locking or Unlocking multiple TV shows would lead to loss of each shows premiered date


Link removed, please download from http://mediacompanion.codeplex.com/

Regards

Billy

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/


Last edited by billyad2000 on Wed Dec 22, 2010 5:27 pm; edited 1 time in total
Back to top Go down
View user profile http://billyad2000.co.uk
MarkC
Senior Member
Senior Member


Posts : 54
Join date : 2008-09-27

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Oct 11, 2010 3:34 am

Thanks for the update Billy,

Sorry to be the first to jump on it but have noticed that for Movies, on initial scrape it does NOT scrape the <duration> under media tags. In fact if you batch re-scrape it removes this field from all .nfo's the only way to get it back is to right click on the movie in the list, Rescape Specific, Media Tags. Using rescrape specific, runtime, from files does not generate the <duration> either. This may cause issues for XBMC as the last time I checked the dharma branch uses <duration> rather than <runtime> but this may have changed....

Fix for this for now is to select all your recently modified movies in the list, right click, rescrape specific, media tags.

Would be grateful if you could get this changed please.

Thanks,

Mark.

EDIT: this is obviously with the option "Save Media Runtime as numerical only" enabled.
Back to top Go down
View user profile
GRiM69
New User
New User


Posts : 1
Join date : 2010-10-11

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Oct 11, 2010 4:53 pm

MarkC wrote:
this is obviously with the option "Save Media Runtime as numerical only" enabled.


Where is this setting? I cannot find it.


Nevermind, I found it. Was a little slow this morning, hadn't had my coffee yet Smile
Back to top Go down
View user profile
lupis42
New User
New User


Posts : 5
Join date : 2010-02-14

PostSubject: Re: New Release Media Companion gen2 3.400   Sun Oct 17, 2010 5:16 pm

Worked awesomely, thanks!
Back to top Go down
View user profile
ranger rob
Junior Member
Junior Member


Posts : 23
Join date : 2010-06-02

PostSubject: Re: New Release Media Companion gen2 3.400   Wed Oct 20, 2010 4:32 pm

I still can't scrape movies with the new build. It get stuck on scraping the first one and won't scrape it. I have removed the one that would have been first in case it was a problem file of some sort and it still gets stuck on the 'second' one.

in addition, I cannot rescrape existing movies that are missing info.
Back to top Go down
View user profile
Meez10
Junior Member
Junior Member


Posts : 15
Join date : 2010-03-28

PostSubject: Re: New Release Media Companion gen2 3.400   Wed Oct 20, 2010 7:55 pm

the newest builds of XBMC4Xbox only support the <runtime> tag of tv episodes now instead of the duration tag. is there a way to add the duration to the <runtime> of the older .nfo files? i know you can do this for movies. i tried the batch wizard but it didn't work. at least it didn't write anything to the <runtime> tag.

Edit: looks like tv episodes' runtime are numerical only now, just like the movies. if the runtime is blank in the library, it will get filled in when you play the video. i would love to batch fix my .nfo's in MC.
Back to top Go down
View user profile
Meez10
Junior Member
Junior Member


Posts : 15
Join date : 2010-03-28

PostSubject: Re: New Release Media Companion gen2 3.400   Fri Oct 22, 2010 6:34 pm

i think there might be a bug with scraping TV episodes if the TV show contains parentheses, ( ).

The Office (US)
Parenthood (2010)

they were not able to retrieve new episodes.
Back to top Go down
View user profile
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Oct 23, 2010 2:28 am

Meez10 wrote:
i think there might be a bug with scraping TV episodes if the TV show contains parentheses, ( ).

The Office (US)
Parenthood (2010)

they were not able to retrieve new episodes.

Parenthood (2010) is scraping fine for me.
Back to top Go down
View user profile
Meez10
Junior Member
Junior Member


Posts : 15
Join date : 2010-03-28

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Oct 23, 2010 5:06 am

really? it's doesn't scrape for me for some reason. i have to manually make the .nfo and copy the info from tvdb. i'll test this out some more.
Back to top Go down
View user profile
coolmanlr
New User
New User


Posts : 5
Join date : 2010-04-15

PostSubject: Link dead   Sat Oct 30, 2010 11:32 am

looks like the link is dead???? Neutral
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Oct 30, 2010 4:22 pm

nope - its fine

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
coolmanlr
New User
New User


Posts : 5
Join date : 2010-04-15

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Oct 30, 2010 5:30 pm

ok weird, getting a server error in Safari, and a DNS error in Firefox if trying to click the link or right click and save....
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Sun Oct 31, 2010 10:29 am

Working OK here using Chrome or IE
Back to top Go down
View user profile
coolmanlr
New User
New User


Posts : 5
Join date : 2010-04-15

PostSubject: Re: New Release Media Companion gen2 3.400   Sun Oct 31, 2010 11:02 am

cheers managed to download with IE, cheers
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Nov 01, 2010 12:52 pm

Hey! I bet you never thought IE could be useful Shocked
Back to top Go down
View user profile
dchoe
New User
New User


Posts : 4
Join date : 2009-04-14

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Nov 01, 2010 7:28 pm

for tv shows - i have the 'auto create screenshot...' unchecked, but it looks like a screenshot is indeed being created if it's not on tvdb
Back to top Go down
View user profile
greybeard
Junior Member
Junior Member


Posts : 17
Join date : 2009-12-04

PostSubject: export to xml implemented yet?   Sat Nov 20, 2010 7:28 pm

I posted a couple of days ago to a month-or-so-old thread asking about export to xml. I have opened the export tab in MC 3.400 and edited the paths so that my HTPC should be able to find them on SMB/CIFS. I do not see how to actually get the .xml file to import to XBMC on the HTPC. Is this feature not fully implemented yet? Nothing happens when I click on the "Tools" button at the top.

PS
Poking around just now I do find the file pathsubstitution.xml . Funny, when I edited the paths on the export tab I did not notice that it only offered me my movie directories, not my tvshow dirs.
Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Fri Dec 10, 2010 2:45 am

I'm having issues scraping TV shows. It seems to put the same fanart for all shows. Not sure why this is happening. My folder structure is as follows

D:\[TV]\24\Season 01 - DVDRiP XviD\
E:\[TV]\Hogan Knows Best\Season 01 - DVDRiP XviD\
F:\[TV]\Six Feet Under\Season 01 - DVDRiP XviD\

All shows on the first drive have the 24 fanart, now all shows on my 2nd drive have Hogan Knows Best fanart. I guess I'll see what happens when it gets too the 3rd drive....
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Fri Dec 10, 2010 8:09 am

Grubsy, first thing to do is confirm that infact you do have different fanart in each tvshow folder (fanart.jpg)

Second, have you tried selecting a TV show that is incorrect & choosing the TV Show Selector tab to rescrape it? (Make sure you have the 'Check this is you want to overwrite existing image files')

Cheers
Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Fri Dec 10, 2010 11:26 am

StormyKnight wrote:
Grubsy, first thing to do is confirm that infact you do have different fanart in each tvshow folder (fanart.jpg)

I've checked and their is definatley a fanart.jpg in each folder. I found that it was the fan art from the first show scanned (I did 2 scans hence the 24 & Hogan Knows Best fan arts)

StormyKnight wrote:
Second, have you tried selecting a TV show that is incorrect & choosing the TV Show Selector tab to rescrape it? (Make sure you have the 'Check this is you want to overwrite existing image files')

Just tried this and it worked fine. I have about 250 shows; so as you'd imagine I'm not real keen to have to do this for every one.

Cheers
Grubs
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Fri Dec 10, 2010 12:50 pm

You could try the batch rescraper wizard in the TVSHOWS menu, then select search & download missing fanart....At least that will be automatic & save you from manually doing each show...

You will need to first delete all of the current fanart.jpg so that MC will think you have none loaded...

The easiest way is to do a windows search in your TV show root folder for fanart.jpg & then delete them from the search list when its done.

Cheers
Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Fri Dec 10, 2010 3:23 pm

StormyKnight wrote:
You could try the batch rescraper wizard in the TVSHOWS menu, then select search & download missing fanart....At least that will be automatic & save you from manually doing each show...

You will need to first delete all of the current fanart.jpg so that MC will think you have none loaded...

The easiest way is to do a windows search in your TV show root folder for fanart.jpg & then delete them from the search list when its done.

Cheers

Deleted all the fan art & went to do the batch rescraper wizard in TV Shows, but I don't think it exists? I only see it in the Movies menu
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Dec 11, 2010 1:42 am

Definitely in V3.400 under TVShows menu - 6th item down......

PS it was added in V3.317 Embarassed
Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Dec 11, 2010 3:31 am

I'm not sure how, but somehow I'd downloaded 3.260 Smile Just downloading 3.400 now. Will see how i get on

Edit: Damn, looks to be doing the same thing. The fanart from the first show it scans is being added to all shows after than... very strange. Could it be something with how I have my season folders name? It's strange that the Wide Banners work fine.
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Dec 11, 2010 5:10 am

No, season folders do not make a difference they can be named anything or they do not have to exist at all. i.e. you can have all of your episodes in the tvshow root for all of your seasons.

In times like these I create a fresh install of MC in a different directory completely & create some fresh dummy shows in a new folder on my local PC. Add them to the new MC & see if they behave correctly. This will help to sort out where the issues lie. It could be a NAS issue or a config issue, but a fresh install will use the default settings incase that is the issue.

(A Dummy Show is just a tvshow folder & say a new text document renamed to the TV show.avi so MC sees it as an actual video file even though it has zero length. It is used for testing purposes & saves copying large amounts of real files & the time that takes.)


Then I see if that works...it should since v3.400 works for most of us.

Cheers
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: New Release Media Companion gen2 3.400   

Back to top Go down
 
New Release Media Companion gen2 3.400
View previous topic View next topic Back to top 
Page 1 of 2Go to page : 1, 2  Next
 Similar topics
-
» Slow release pain medication not interfering with triptans...
» Watermelon Studios Aims For A January 2nd Release of Pier Solar: HD For The Wii U eshop!
» Lawyers warn social media over Mikaeel case
» Social Media Makeover!
» [ANSWERED] Media Creation Tool

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Announcements-
Jump to: