Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 New Release Media Companion gen2 3.400

View previous topic View next topic Go down 
Go to page : Previous  1, 2
AuthorMessage
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Dec 13, 2010 2:13 am

Still having issues scraping. I made a folder with a fresh copy of MC. Then made c:\Users\Grubsy\Desktop\TV\ put 4 tv shows folders in there with a dummy .avi files. The wide posters scanned fine, but still no fan art.

I've just added a root folder then used the Add folders from Roots button.

My normal tv folders are D:\[TV]\, E:\[TV]\ & F:\[TV]\. I thought the [ ] might be causing issues.
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Dec 13, 2010 12:21 pm

Questions...
1. When you add folders from roots did those shows appear in the show list on the left in the main browser? You should have fanart at this stage & you will need to click on the lock symbol to tell MC that it has scraped the right tvshow name.
2. Have you got checked in the preferences to download fanart (not sure if it is on by default)
3. What windows version are you using.... Vista & Win7 probably won't allow you to write the nfo's to a desktop folder, can you try something like c:\TV\Top Gear\
4. What is one of your shows not working at the moment? I can try it & see if it works for me...

Cheers

Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Mon Dec 13, 2010 3:15 pm

StormyKnight wrote:
1. When you add folders from roots did those shows appear in the show list on the left in the main browser? You should have fanart at this stage & you will need to click on the lock symbol to tell MC that it has scraped the right tvshow name.
Yes. All the shows appear on the left. I've tried changing a few to 'Open' and then using the Batch Rescraper Wizard and selecting fan art only and they all end up with the same fan art from the first show scanned.

StormyKnight wrote:
2. Have you got checked in the preferences to download fanart (not sure if it is on by default)
Yes, this is enabled

StormyKnight wrote:
3. What windows version are you using.... Vista & Win7 probably won't allow you to write the nfo's to a desktop folder, can you try something like c:\TV\Top Gear\
Windows 7 Professional (x86). I've just created the folder structure below & included the first 5 shows & a dummy .avi as well.

D:\[TV2]\8th And Ocean\8th And Ocean S01 E01.avi
D:\[TV2]\24\24 S01 E01.avi
D:\[TV2]\30 Rock\30 Rock S01 E01.avi
D:\[TV2]\90210\90210 S01 E01.avi
D:\[TV2]\Afro Samurai\Afro Samurai S01 E01.avi

With a fresh copy of media companion in C:\Program Files\Media Companion (v3.400) I've done the following

TV Shows -> TV Preferences -> Select season-all.tbn (Banner), Default TV Show Thumbnails (Banner), Auto create screenshot if TVDB does not have one -> Save Changes
Folders -> Browse for Folder (Root Folders) -> D:\[TV2] -> Add folders from Roots -> Save Changes
(Status Bar) -> Scraping TV Shows, 1 remaining.

If I click Main Browser it asks me to save again, then there are no shows listed, Scraping TV Shows, 1 remaining is still shown in the status bar. This is strange. Doing the above I can't get the shows to stay in the list on the right hand side under folders, they're just cleared each time I change to Main Browser.

I'm watching what is happening on the disk with the built-in resource monitor and it keeps writing files in D:\[TV2]\24\.actors but it looks to be just writing the same files that already exist... strange.

Edit: I left it run for quite some time & it looks to have eventually worked. Maybe I can just get it to skip the actor thumbs to start with? The Show folders are actually listed in 'Folders' on the right hand side now too.

StormyKnight wrote:
4. What is one of your shows not working at the moment? I can try it & see if it works for me...
When I first ran it earlier. It scanned the wide banner fine for all shows, but they all had the fan art from '24'
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Tue Dec 14, 2010 2:00 am

Its good that @ least some of it now seems to work...

When you select the folders in the preferences & then save that is when MC will try & locate each of the folders on TVDB & download the information for each show. Assuming there is no tvshow.nfo to start with....

It can take some time to gather the 1st fanart, poster & actors information.

The status bar down the bottom gives you an indication of where its up to & it will populate the list on the left in real time as each show is done.

Some time ago there was a bug in MC where if it showed a fanart but you then selected another show that did not have fanart then the previous fanart would show. Now that should be fixed now & there is also a default fanart picture that should display if no fanart is found for a particular show.

I suspect a fair bit of your issues are to do with Win7 & UAC (User Access Control). Any of the user folders, like program files & desktop cannot be written by a program, so MC cannot create the nfo files it needs to & also it cannot create its own configuration files. Unfortunately MC was written in the days of XP were this was OK. The workaround at the moment is to put MC & your video files in locations that Win7 allows the program full access such as C:\Media Companion & C:\Videos as an example. Videos on other drives either local or networked should also be fine.

Also I see you have your episodes named with a space between the S01 & the E01. I'm not sure if the regex handles that. The usually format is S01E01. One thing to remember is that the regex's are tried in order as they are listed in the preferences & they are applied to the entire path not just the filename & extension. In addition the default ones work left to right thru the path. This can mean for example that a folder name can be interpreted as a series/episode number incorrectly.

Cheers
Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Tue Dec 14, 2010 2:25 am

I think I've got it working now. I disabled the actor option on general preferences & also tv preferences. I've also set UAC to off, I was trying it on the lowest level.

I think my naming 'S01 E01' is ok as it seems to find episodes fine. I'm actually thinking about renaming them all without a space. I have ~12,000 episodes so I want to make sure I choose the most compatible option Smile

Just started using theRenamer so I want to make sure I choose one that it can do also.

I'm also having an issue where the windows doesn't seem to be showing all the info

Screen Shot

See IMDB, Cert etc at the bottom. Even when I make it full screen it still looks the same.

Edit: The scraping seems to be working fine now. Wonder if it was all caused by UAC? Any thoughts on the display issue above?
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Tue Dec 14, 2010 7:25 am

Yep...

The status bar down the bottom will be over the lower text whilst its active. After that it will disappear.

You may have also another issue relating to Vista/Win7...

The screen dpi by default in XP was 96dpi. With larger resolution screens that was becoming too small to see so Vista & Win7 may change that setting from 96 to higher value. Unfortunately MC doesn't take this into account when it shows text so the text is too big & often overlaps etc...

You can try & set it back to 96 if you want just be aware that it will affect your whole system. Anything written for Vista or Win7 should adapt however without trouble.

Cheers
Back to top Go down
View user profile
Grubsy
Junior Member
Junior Member


Posts : 11
Join date : 2010-04-19
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Wed Dec 15, 2010 10:31 am

StormyKnight wrote:
Yep...

The status bar down the bottom will be over the lower text whilst its active. After that it will disappear.

You may have also another issue relating to Vista/Win7...

The screen dpi by default in XP was 96dpi. With larger resolution screens that was becoming too small to see so Vista & Win7 may change that setting from 96 to higher value. Unfortunately MC doesn't take this into account when it shows text so the text is too big & often overlaps etc...

You can try & set it back to 96 if you want just be aware that it will affect your whole system. Anything written for Vista or Win7 should adapt however without trouble.

Cheers

Ok about the status bar Smile

I actually have it set at the defaul 96dpi...

Got a lot of work done on my library last night. Looking good now. Got all 12,000+ epsidoes renamed and all shows scraped. Just working on scraping the episodes now

Is it possible to stop the word 'The' being placed at the end of the show name? i.e. The Simpsons instead of Simpsons, The. I would like this for movies also as that is how I have the folder names on my drives.
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: New Release Media Companion gen2 3.400   Wed Dec 15, 2010 12:13 pm

Grubsy wrote:
Is it possible to stop the word 'The' being placed at the end of the show name? i.e. The Simpsons instead of Simpsons, The. I would like this for movies also as that is how I have the folder names on my drives.

Sorry no. This is a carry on from XBMC where it is actually optional.

You can re-edit the relevant nfo's if you like & then perform a rebuild so that MC re-reads the nfo's & creates the list in the order you would like.....

For movies you can change the sort order text so that they are sorted alphabetically as you desire.

Cheers



Back to top Go down
View user profile
ekohenfri
New User
New User


Posts : 1
Join date : 2010-12-18

PostSubject: Connection Setting   Sat Dec 18, 2010 5:15 am

Its a great program, I can easily manage my movies by importing its nfo to XBMC.

But in my office there is proxy with authentication request., thus this program cannot connect to imdb.

The feature of connection setting for setting the proxy would be very helpful for me.

By the way thanks for the great program.

regards,
eko henfri
Back to top Go down
View user profile
angeoand
Junior Member
Junior Member


Posts : 25
Join date : 2011-03-11

PostSubject: hello    Fri Mar 11, 2011 12:53 pm

alien alien alien @ @ @ @



I am in love with the article,it is so excellent~~
I love the style~~Hope author will get more attention~~
crystal jewelry sets
Back to top Go down
View user profile
Acheson63
Senior Member
Senior Member


Posts : 81
Join date : 2011-05-16

PostSubject: Re: New Release Media Companion gen2 3.400   Tue Jun 07, 2011 5:25 am

I always here that short girls should never wear ball gown dresses...But I've always invisioned myself wearing ball gown dress.... So does the rule apply to all short girls...or can a short girl pull one off with the right dress/shoes?
Prom Dresses Under 200,[B][URL=http://www.goodgoodschina.com/categories/clothing-apparel/prom-dresses/2011]
Back to top Go down
View user profile
abraxas971
New User
New User


Posts : 1
Join date : 2011-07-02

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Jul 02, 2011 9:33 pm

I downloaded this version as the previous ones wouldn't scrape plot info for the movies.

This one does and I used it get all my movies edited properly.

The weird thing now is when scanning my movies in, XBMC will not list them in order by name.
Not ascending or descending nor in 4 different skins.

I take out the .nfo's and rescan and it lists them by name in order.

I've already ask this on XBMC forums with no concrete answer so I'm wondering why that is.
Back to top Go down
View user profile
MartinHJ
New User
New User


Posts : 1
Join date : 2011-07-28

PostSubject: Re: New Release Media Companion gen2 3.400   Thu Jul 28, 2011 10:22 am

StormyKnight wrote:
Yep...

The status bar down the bottom will be over the lower text whilst its active. After that it will disappear.

You may have also another issue relating to Vista/Win7...

The screen dpi by default in XP was 96dpi. With larger resolution screens that was becoming too small to see so Vista & Win7 may change that setting from 96 to higher value. Unfortunately MC doesn't take this into account when it shows text so the text is too big & often overlaps etc...

You can try & set it back to 96 if you want just be aware that it will affect your whole system. Anything written for Vista or Win7 should adapt however without trouble.

Cheers

Do you have your status bar set to auto hide (ie it raises and lower automagically). I found disabling this so it is permanently visible solved the problem

Martin
Back to top Go down
View user profile
theTechnician
New User
New User


Posts : 1
Join date : 2011-08-06

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Aug 06, 2011 2:12 pm

My movies are still not scraping correctly Sad

I updated from 3.14 (I think) as yesterday the scraping stopped working for any new movies. After updating the movies still don't scrape correctly.
New movies get the title, genre, cert, runtime, studio and actor ... nothing else. No fanart, poster, outline etc.
If I go to "Change Movie", the movie search on IMDB loads. I can then select the movie and click on "GO" to rescrape. This doesn't update anything, but does insert "scraper error" in some of the fields.

Any suggestions? I did a fresh update from the previous version, so all the cache was emptied.
Back to top Go down
View user profile
hell_spawn27
New User
New User


Posts : 3
Join date : 2009-03-23

PostSubject: Re: New Release Media Companion gen2 3.400   Sat Aug 20, 2011 8:09 am

Yep on 3.4000, I am getting scraper error for the following fields

Director
Credits
Outline - Empty
Plot - Empty
Tagline - Empty

Can it be possible that IMDB has made changes which are effecting this? Help appreciated !

Back to top Go down
View user profile
IamChappy
New User
New User


Posts : 1
Join date : 2011-08-23

PostSubject: Re: New Release Media Companion gen2 3.400   Tue Aug 23, 2011 8:24 pm

hell_spawn27 wrote:
Yep on 3.4000, I am getting scraper error for the following fields

Director
Credits
Outline - Empty
Plot - Empty
Tagline - Empty

Can it be possible that IMDB has made changes which are effecting this? Help appreciated !


I am getting the same thing as well. Windows 7 Pro 32 Bit version 3.4 for Media Companion. I really like this program, I hope it gets fixed soon?
Back to top Go down
View user profile
VCDmonger
New User
New User


Posts : 1
Join date : 2010-10-19

PostSubject: Re: New Release Media Companion gen2 3.400   Wed Aug 24, 2011 6:01 am

+1 here, except that I also seem to not be getting ratings.
Using 3.400 on Windows 7 x64.
Back to top Go down
View user profile
otb
New User
New User


Posts : 5
Join date : 2010-06-28

PostSubject: new website for downloads   Mon Aug 29, 2011 10:01 pm

http://mediacompanion.codeplex.com

I had the same problems w/ 3.4 then upgraded to 3.4.1.5b.
Back to top Go down
View user profile
angusc
New User
New User


Posts : 1
Join date : 2013-11-03

PostSubject: How to correctly name multiple movie files ie CD1, CD2 etc......   Tue Nov 05, 2013 7:33 pm

I just discovered Media |COmpanion and i love it....but i got a problem with split movies that i did not have before. now if i scan a folder with Blahblah CD1 and Blahblah CD2 in the one folder i end up with movie art and info for both files and thus a double entry in MC and XBMC.

I currently have MC set up to rename folder and files and i notice that when it has run that the CD1 file has been changed to moviename.avi but CD2 file has been changed to moviename.avi (CD2). Now when playing part 1 the movie just stops at the end of the file and does not start playing part 2.........

Final question, how tp stop MC from creating movie COLLECTION folders? now i have "The Jaws Collection" rather than just the only film that i have from this collection so i would like to keep it that way in the movie listings......
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: New Release Media Companion gen2 3.400   

Back to top Go down
 
New Release Media Companion gen2 3.400
View previous topic View next topic Back to top 
Page 2 of 2Go to page : Previous  1, 2
 Similar topics
-
» Slow release pain medication not interfering with triptans...
» Watermelon Studios Aims For A January 2nd Release of Pier Solar: HD For The Wii U eshop!
» Lawyers warn social media over Mikaeel case
» Social Media Makeover!
» [ANSWERED] Media Creation Tool

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Announcements-
Jump to: