Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 MC v3.4 Creating Multiple NFOs on Single File Films

View previous topic View next topic Go down 
AuthorMessage
DataByne
New User
New User


Posts : 5
Join date : 2011-02-17

PostSubject: MC v3.4 Creating Multiple NFOs on Single File Films   Fri Feb 18, 2011 9:54 pm

I've read of others who've experienced MC creating multiple .NFO files for a single film, but in their cases the films have been split between multiple files. I've had the same experience, but not with those multi-file films.

The files it duplicates seems to be similar in their selection (so far every Bond film in processes gets cloned, the same for Indiana Jones and the Ocean films, but it decided only Mad Max 3 should be so lucky in that series). Additionally, anytime I delete either the duplicate .NFOs or all of the .NFOs for one of these films, then choose "Search for New Movies", it duplicates the same films all over again.

This also happened when I used the last version of MC.

I'm at a loss as to what's causing this, I haven't been able to perform a complete scan of my movie collection since it is scanning so many films twice. I'm currently trying letting it finish but it's been over ten hours (in the past I canceled the search when I saw the duplicates).

Further more, the program's not been finding the majority of films, but I suspect this is unrelated and has more to do with my connection. I'm fine with doing a batch rescrape after I weed out the duplicates so that it can find everything.

Things you may wish to know,

  • I'm using v3.4 on a 64-bit Windows 7 operating system.
  • My folder structure is \Movies\Film Title [date]\Film Title.avi
  • I have not used another scraping program that is fouling up the works with its .nfos
  • I have MC set to "Use folder names for scraping"
  • I'm only uploading one of my "Online-Movies" (though they're on an external drive)
  • Even when my computer has a solid internet connection it still makes these copies
  • My computer is not set to go into sleep or standby mode


Thanks in advance for any help and especially for the program (other than the cloning I really like it)
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Sat Feb 19, 2011 3:16 am

When you delete the nfo's you then need to perform a rebuild. This will run through your folders & rebuild the database from only those nfo's that actually exist.

If you are still getting duplicates, then you will have two nfo's the same somewhere in your search path (they can be anywhere & in different folders...)

Cheers
Back to top Go down
View user profile
DataByne
New User
New User


Posts : 5
Join date : 2011-02-17

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Sat Feb 19, 2011 10:10 am

I've been rebuilding, so unfortunately that's not the issue (though it does remove the deleted duplicates from the list until I search for new movies again).

The duplicate NFOs are made in a different naming format so that they can be in the same folder as the originals (I'm guessing). That format is "._Movie Title.nfo" instead of "Move Title.nfo". (Often times duplicate fanart and TBN files will be made as well.)

Thanks again.
Back to top Go down
View user profile
DataByne
New User
New User


Posts : 5
Join date : 2011-02-17

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Sat Feb 19, 2011 10:49 pm

Alright, it finally finished scraping so here's a snippet of the log entry from two of the problem files.

Funny note, the movie "Them!" is added to the movie list as "!, The". I guess that's a separate bug (which is a pun if you know the movie!).

Code:
Subfolder added :- I:\Movies\Them! [1954]
Subfolder added :- I:\Movies\You Kill Me [2007]

2 New movies found in directory:- I:\Movies\Them! [1954]
2 New movies found in directory:- I:\Movies\You Kill Me [2007]

Filename is: I:\Movies\Them! [1954]\._Them!.avi
Title according to settings is: "Them!"

Filename is: I:\Movies\Them! [1954]\Them!.avi
Title according to settings is: "Them!"

Filename is: I:\Movies\You Kill Me [2007]\._You Kill Me.mp4
Title according to settings is: "You Kill Me"

Filename is: I:\Movies\You Kill Me [2007]\You Kill Me.mp4
Title according to settings is: "You Kill Me"

Scraping Title:- Them! [1954]
Output filename:- I:\Movies\Them! [1954]\._Them!.nfo
Poster Path:- I:\Movies\Them! [1954]\._Them!.tbn
Fanart Path:- I:\Movies\Them! [1954]\._Them!-fanart.jpg
NFO does not exist
Checking filename for IMDB ID
No IMDB ID found
Checking for Movie year in filename
Year found for movie:- 1954
Cleaned Title for search :- Them!
Movie Body Scraped OKActors scraped OKPoster scraped and saved OK
Saving folder.jpg To Path :- I:\Movies\Them! [1954]\folder.jpg
Poster also saved as "folder.jpg" OK
Saving Fanart As :- I:\Movies\Them! [1954]\._Them!-fanart.jpg
Fanart not resized
Movie added to list

Scraping Title:- Them! [1954]
Output filename:- I:\Movies\Them! [1954]\Them!.nfo
Poster Path:- I:\Movies\Them! [1954]\Them!.tbn
Fanart Path:- I:\Movies\Them! [1954]\Them!-fanart.jpg
NFO does not exist
Checking filename for IMDB ID
No IMDB ID found
Checking for Movie year in filename
Year found for movie:- 1954
Cleaned Title for search :- Them!
Movie Body Scraped OKActors scraped OKHD Tags Added OK
Poster scraped and saved OK
folder.jpg Not Saved to :- I:\Movies\Them! [1954]\folder.jpg, file already exists
Saving Fanart As :- I:\Movies\Them! [1954]\Them!-fanart.jpg
Fanart not resized
Movie added to list

Scraping Title:- You Kill Me [2007]
Output filename:- I:\Movies\You Kill Me [2007]\._You Kill Me.nfo
Poster Path:- I:\Movies\You Kill Me [2007]\._You Kill Me.tbn
Fanart Path:- I:\Movies\You Kill Me [2007]\._You Kill Me-fanart.jpg
NFO does not exist
Checking filename for IMDB ID
No IMDB ID found
Checking for Movie year in filename
Year found for movie:- 2007
Cleaned Title for search :- You Kill Me
Movie Body Scraped OKActors scraped OKPoster scraped and saved OK
Saving folder.jpg To Path :- I:\Movies\You Kill Me [2007]\folder.jpg
Poster also saved as "folder.jpg" OK
Saving Fanart As :- I:\Movies\You Kill Me [2007]\._You Kill Me-fanart.jpg
Fanart not resized
Movie added to list

Scraping Title:- You Kill Me [2007]
Output filename:- I:\Movies\You Kill Me [2007]\You Kill Me.nfo
Poster Path:- I:\Movies\You Kill Me [2007]\You Kill Me.tbn
Fanart Path:- I:\Movies\You Kill Me [2007]\You Kill Me-fanart.jpg
NFO does not exist
Checking filename for IMDB ID
No IMDB ID found
Checking for Movie year in filename
Year found for movie:- 2007
Cleaned Title for search :- You Kill Me
Movie Body Scraped OKActors scraped OKHD Tags Added OK
Poster scraped and saved OK
folder.jpg Not Saved to :- I:\Movies\You Kill Me [2007]\folder.jpg, file already exists
Saving Fanart As :- I:\Movies\You Kill Me [2007]\You Kill Me-fanart.jpg
Fanart not resized
Movie added to list
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Sun Feb 20, 2011 12:56 pm

From what I can see you start with a single avi "Them!.avi" right?

The something happens & you end up with two avi's "Them!.avi" & "_Them!.avi" right?

MC will see those two avi's as two diffrent movies & try to scrape them both...

Now MC also doesn't rename movie files at the moment so I ican't see MC creating your duplicates.....

Do you run any other programs that might be doing this?

Cheers
Back to top Go down
View user profile
DataByne
New User
New User


Posts : 5
Join date : 2011-02-17

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Sun Feb 20, 2011 10:42 pm

I just went back and checked and was about to write a desperate note about how there were no double movie files, when it occurred to me to turn on hidden files.

Sure enough, a little 82 byte movie file magically appeared. I don't know where these things came from. I haven't watched any of the afflicted movies on XBMC or with VLC, though I did transfer all of the files from my Mac. Maybe they're residual artifacts from the copying process...

Anyways, thanks for the help! I'm sorry I took up space on the bug page for something that turned out not to be MC's fault (unless it scanning hidden files counts, in which case I was happy to bring this to light).
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Mon Feb 21, 2011 2:29 am

Thanks, I was aware of the hidden file operation but didn't put it with your issue, it was quite some time ago that became apparent.

Cheers
Back to top Go down
View user profile
wedd123
Junior Member
Junior Member


Posts : 25
Join date : 2011-05-12

PostSubject: Thanks, I was aware of the hidden file operation but didn't put it with your issue, it was quite some time ago that became apparent.   Thu May 19, 2011 12:33 pm

Thanks, I was aware of the hidden file operation but didn't put it with your issue, it was quite some time ago that became apparent.
crystal tiaras

crystal ring
Back to top Go down
View user profile
Acheson63
Senior Member
Senior Member


Posts : 81
Join date : 2011-05-16

PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   Thu Jun 09, 2011 11:13 am

So does the final tail top, which flare out from the leg length together with eye-feasting ruffles. Needless to say, the particular lace trimmed keyhole styled open back style is cigarette smoking hot in 2010 for a spectacular effect.Princess Wedding Dresses
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: MC v3.4 Creating Multiple NFOs on Single File Films   

Back to top Go down
 
MC v3.4 Creating Multiple NFOs on Single File Films
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Windows Reducer 8.1 Tip: Improving the Speed while creating multiple .iso files
» Creating the account (URL) globally and using that variable where ever it needed
» [Help] how to add multiple testcases in a TestSuite through Selenium IDE
» how execute multiple tests in TestNg using ant?
» how run multiple tests in junit?

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Bug Discussion-
Jump to: