Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 Stacked NFO/Fanart/TBN problem

View previous topic View next topic Go down 
AuthorMessage
feerlessleadr
New User
New User


Posts : 9
Join date : 2008-10-17

PostSubject: Stacked NFO/Fanart/TBN problem   Wed Dec 24, 2008 5:30 pm

Hi Billy

I downloaded the most recent version 2.085 and am having a number of problems.

I read in the anouncement for 2.071 that if I have fanart and poster tbn's not named with the default naming convention then it would offer to rename them for me. Well I have quite a few of stacked movies that all have their nfo's tbn's and fanart's names xxxxx-cd1.nfo/tbn/fanart or whatever.

I figured I might be doing something wrong, so I deleted ALL of my nfo's tbn's and fanart's and re-scraped everything, and while I am happy that the program scraped all the correct movies, it is still naming the nfo tbn and fanart using the cd1 filename and not the stacked filename.

an example of one filename is "across.the.universe.dvdrip.xvid-imbt-CD1.nfo"

Is there anything that I am doing wrong? Is there something that I should have deleted that I didn't in order for this to name these files correctly?

::EDIT:: well i just happened to try some movies that were in a folder on my desktop (previously scraped my an older version of media companion) and when I started it up, it asked me if I wanted to rename the files. The other movies that I was having a problem with are on a USB drive connected to the computer. Is the USB drive the reason that Media companion isn't asking me to rename the files, or naming the files correctly in the first place?

::EDIT 2:: Well it seems like I have not fixed the problem. I deleted the nfo/tbn/fanart from 2 movies that are being scraped incorrectly and will post the log here:

Starting Folder Scan

2 New Movies Found

Searching IMDB For 21 (2008)
IMDB ID found :- tt0478087
nfo saved as :- C:\Users\Kevin\Desktop\Temp Movies\21 (2008)\21-rpck-dvdrip-xvid-cd1.nfo
Downloading Movie Thumbnail at URL :- C:\Users\Kevin\Desktop\Temp Movies\21 (2008)\21-rpck-dvdrip-xvid.tbn
Saving Thumbnail To Path :- C:\Users\Kevin\Desktop\Temp Movies\21 (2008)\21-rpck-dvdrip-xvid.tbn
Saving folder.jpg To Path :- C:\Users\Kevin\Desktop\Temp Movies\21 (2008)\folder.jpg
Fanart URL is http://api.themoviedb.org/2.0/Movie.imdbLookup?imdb_id=tt0478087&api_key=3f026194412846e530a208cf8a39e9cb
Saving Fanart As :- C:\Users\Kevin\Desktop\Temp Movies\21 (2008)\21-rpck-dvdrip-xvid-fanart.jpg

Searching IMDB For 300
IMDB ID found :- tt0416449
nfo saved as :- C:\Users\Kevin\Desktop\Temp Movies\300\300 (2006) CD1.nfo
Downloading Movie Thumbnail at URL :- C:\Users\Kevin\Desktop\Temp Movies\300\300 (2006) CD1.tbn
Saving Thumbnail To Path :- C:\Users\Kevin\Desktop\Temp Movies\300\300 (2006) CD1.tbn
Saving folder.jpg To Path :- C:\Users\Kevin\Desktop\Temp Movies\300\folder.jpg
Fanart URL is http://api.themoviedb.org/2.0/Movie.imdbLookup?imdb_id=tt0416449&api_key=3f026194412846e530a208cf8a39e9cb
Saving Fanart As :- C:\Users\Kevin\Desktop\Temp Movies\300\300 (2006) CD1-fanart.jpg

The movie 21 saves the tbn and fanart correctly, but still saves the nfo as cd1.nfo, while for the movie 300 everything is saved under the cd1 naming convention. I tried adding using a period instead of using a space between the year and the cd for 300 but to no avail.

I should also note that media companion recognizes that 300 is a stacked file as it only produces the nfo and tbn and fanart for cd1 and not cd2
Back to top Go down
View user profile
feerlessleadr
New User
New User


Posts : 9
Join date : 2008-10-17

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Mon Dec 29, 2008 8:50 pm

anyone?
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Tue Dec 30, 2008 12:13 am

Sounds like a bugfix is needed, I'll look into it tomorrow

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Tue Dec 30, 2008 3:22 am

I've found the problem causing this, a simple oversight, the regex was only checking for lowercase matches, it will be fixed for the next build.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
feerlessleadr
New User
New User


Posts : 9
Join date : 2008-10-17

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Tue Dec 30, 2008 4:13 pm

ahh, I just figured that out.

Thanks Billy


Awesome Program!!!
Back to top Go down
View user profile
SmokeHacker
Junior Member
Junior Member


Posts : 10
Join date : 2009-01-07

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Wed Jan 07, 2009 10:12 am

It's not exactly the same, but I am having a problem related to this issue and hope someone can help me.

When I grab a poster for a stacked movie ( "biglebowski.cd1.avi" and "biglebowski.cd2.avi" for example ) it creates a "biglebowski.tbn". Is there any way to force Media Companion to create a "biglebowski.cd1.tbn" instead?

The only reason I'm asking this, as I assume removing the ".cd#" part of the filename is actually desired, is because XBMC does not use the stacked thumbnail for some reason. If I add that movie to my XBMC Library with "biglebowski.tbn" it will not show poster art, but if I add it with "biglebowski.cd1.tbn" it works perfectly. All information I've found online says that "biglebowski.tbn" should work, and it does in Files view, but not in Library.

Any ideas?
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Wed Jan 07, 2009 11:24 am

As i've stated previously, you need a newer build of XBMC,

I was informed a few weeks ago that XBMC was now using stacked filenames for .tbn files, and at the same time it no longer supported the old method.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
SmokeHacker
Junior Member
Junior Member


Posts : 10
Join date : 2009-01-07

PostSubject: Re: Stacked NFO/Fanart/TBN problem   Thu Jan 08, 2009 5:27 am

Ah, apologies for not seeing your previous statement on that. Thank you very much.

And, as others have said, Media Companion is an excellent and incredibly useful program. Thank you and keep up the great work!
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Stacked NFO/Fanart/TBN problem   

Back to top Go down
 
Stacked NFO/Fanart/TBN problem
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Problem with Selenium Webdriver
» Profile Customization Problem
» [ANSWERED] Winreducer Install problem
» Problem in playing GTA San Andreas, no Audio card.
» Selenium RC & Dojo controls.

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: XBMC Media Companion Help And Useage-
Jump to: