Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  SearchSearch  RegisterRegister  Log inLog in  

 

 Stops at first movie when scraping

Go down 
AuthorMessage
Specs
New User
New User


Posts : 2
Join date : 2009-08-01

Stops at first movie when scraping Empty
PostSubject: Stops at first movie when scraping   Stops at first movie when scraping Icon_minitimeSat Aug 01, 2009 12:30 am

Hi,

When I scan my movie folder for scraping, it detects 107 movies and then says "Scraping movie 1 of 107" in the bottom left of the status bar.

I can see that it does create an .nfo for the first movie, but never goes any further. It basically gets stuck at the first movie.

When I close the application (have to force it closed because clicking the "STOP" button only brings up a message box telling me that it will stop when it's safe to do so but never does), and reopen it, the first movie's info is listed, and clicking the scan button again, it detects 106 new movies, and the same issue repeats itself...

Any ideas!?

I have the latest version, running on XP Pro SP3.
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Stops at first movie when scraping Empty
PostSubject: Re: Stops at first movie when scraping   Stops at first movie when scraping Icon_minitimeSat Aug 01, 2009 12:33 am

Im looking into it now, it appears to be an issue with the IMPA poster scraper

I will hopefully have it fixed by the end of sunday

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Stops at first movie when scraping Empty
PostSubject: Re: Stops at first movie when scraping   Stops at first movie when scraping Icon_minitimeSat Aug 01, 2009 12:49 am

Strike that last post, it seems that I am the victim of a multithreading issue, I have a monitor.enter statement that is not releasing a thread causing the hang. I am not sure of the cause, if neccesary I can double the code up, but I would rather not. Either way, I will have it fixed by sunday night.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
Specs
New User
New User


Posts : 2
Join date : 2009-08-01

Stops at first movie when scraping Empty
PostSubject: Re: Stops at first movie when scraping   Stops at first movie when scraping Icon_minitimeSun Aug 02, 2009 5:08 pm

Thanks for the update!
Back to top Go down
Sponsored content




Stops at first movie when scraping Empty
PostSubject: Re: Stops at first movie when scraping   Stops at first movie when scraping Icon_minitime

Back to top Go down
 
Stops at first movie when scraping
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Bug Discussion-
Jump to: