Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  SearchSearch  RegisterRegister  Log inLog in  

 

 Still getting error on new versions

Go down 
AuthorMessage
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Still getting error on new versions   Still getting error on new versions Icon_minitimeThu Aug 13, 2009 9:51 am

Hi All,

I had this issue a while ago and despit everything I've troed i can get past it.

I had Vista 32bit, latest Media companion and all updates applied via windows update.

I have .Net 3.5

Evertime i try and load a version of Media companion i get this error:

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: media companion.exe
Problem Signature 02: 3.0.8.7
Problem Signature 03: 4a79e926
Problem Signature 04: Media Companion
Problem Signature 05: 3.0.8.7
Problem Signature 06: 4a79e926
Problem Signature 07: 23
Problem Signature 08: c6
Problem Signature 09: System.InvalidOperationException
OS Version: 6.0.6000.2.0.0.256.1
Locale ID: 3081

Read our privacy statement:
http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

As mentioned I have tried everything i have found mentioned:

Created the app folder myself
ran in compatability mode
ran as admin

Just can't get the app to load. It's a pity cause I love the app!!

Please help.

Esra
Back to top Go down
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeThu Aug 13, 2009 11:03 am

If I remember correctly I don't think Media Companion can run in C:\Program Files on Vista since applications are not allowed to create new files in that folder or to create sub folders.

MC wants to create a sub folder called Settings & put a few files in it like config.xml file. If it can't then this is perhaps why it crashes.


Try putting the MC files in a folder like C:\Media Companion & see if that makes a difference.


Cheers
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeThu Aug 13, 2009 11:12 am

It is quite simple to allow MC to use the users application data folder for the files MC needs to function such as the config and cache file but some people want it to be portable, with all the files in a single folder.

This is one of the reasons that I want someone to create a deployment wizard for MC, it would allow this to be configured when installing.
Nobody has stepped up yet.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/


Last edited by billyad2000 on Thu Aug 13, 2009 11:14 am; edited 1 time in total
Back to top Go down
http://billyad2000.co.uk
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeThu Aug 13, 2009 11:13 am

StormyKnight wrote:
If I remember correctly I don't think Media Companion can run in C:\Program Files on Vista since applications are not allowed to create new files in that folder or to create sub folders.

MC wants to create a sub folder called Settings & put a few files in it like config.xml file. If it can't then this is perhaps why it crashes.


Try putting the MC files in a folder like C:\Media Companion & see if that makes a difference.


Cheers

Just tried that, no change.

Ran as admin in new location too.
Back to top Go down
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeThu Aug 13, 2009 3:25 pm

Any other ideas?

Killing me not to be able to use this app. I have 1400 movies and 81 TV shows!
Back to top Go down
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 12:51 am

StormyKnight wrote:
MC wants to create a sub folder called Settings & put a few files in it like config.xml file. If it can't then this is perhaps why it crashes.

Try putting the MC files in a folder like C:\Media Companion & see if that makes a difference.

If the user can put the files there, they must have permissions... Do .net apps run under a different account (perhaps local system)?

The sysinternals "process monitor" tool could be used to diagnose this (filter out successful file operations).
Back to top Go down
http://dennisbareis.com
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 1:05 am

billyad2000 wrote:
It is quite simple to allow MC to use the users application data folder for the files MC needs to function such as the config and cache file but some people want it to be portable, with all the files in a single folder.

This is one of the reasons that I want someone to create a deployment wizard for MC, it would allow this to be configured when installing.
Nobody has stepped up yet.

As per my previous post, I can do this using MAKEMSI (free tool, written by me) but I'd want pseudo code or some other description of what you'd want in the installer. It builds standard Microsoft Window Installer ".msi" files using simple script.

I'd probably want to start with simple installer without portable related questions (would someone even want an installer for that?). I don't know how MC decides certain things, for example where to put the config files, perhaps its as simple as if the "settings" dir exists use that else in profile, but I don't know all the rules...


Bye,
Dennis

P.S. I too want the app to be portable but its lack of relative filename support means, at least for my purpose, that I need a batch file to invoke MC as it needs to determine where it is and build full (absolute) filenames for the config files.
Back to top Go down
http://dennisbareis.com
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 4:20 am

OK well moving the App to the C:\ has not fixed the issue.

I can create folders here so permissions aren't the issue. I even tried creating a 'Settings' folder but that didn't help.

Having an installer etc would be great, what would be even better would be if I could use the App!!

Any other ideas?
Back to top Go down
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 6:51 am

esra wrote:
OK well moving the App to the C:\ has not fixed the issue.

I can create folders here so permissions aren't the issue. I even tried creating a 'Settings' folder but that didn't help.

Having an installer etc would be great, what would be even better would be if I could use the App!!

Any other ideas?

Maybe similar to:

http://objectmix.com/dotnet/114989-weird-problem.html

Or:
http://74.125.155.132/search?q=cache:uKER7en1TUwJ:blog.majestic12.co.uk/%3Fcat%3D3%26paged%3D2+dot+net+%22Description:+Stopped+working%22&cd=1&hl=en&ct=clnk&gl=au

The first suggests that MC may need a manifest, how to: http://blogs.msdn.com/shawnfa/archive/2006/04/06/568563.aspx

Have you disabled UAC on your computer? If so try enabling as turning it off is known to break things.
Back to top Go down
http://dennisbareis.com
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 7:04 am

I had UAC off but re-enabled it a few days ago to see if that helped. No change.

I'll try the manifest thing and let you know.
Back to top Go down
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 7:42 am

Well I had a read and I can honestly say I have no idea what any of that means.

Just a lowly user here.

Hope this doesn't mean I'll have to wipe that machine and maybe install XP instead?
Back to top Go down
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeFri Aug 14, 2009 9:12 am

esra wrote:
Well I had a read and I can honestly say I have no idea what any of that means.

Just a lowly user here.

Hope this doesn't mean I'll have to wipe that machine and maybe install XP instead?

Sounds like a development step to me, I wonder if anyone else is using Vista, I just did a quick search and I didn't find any posts...
Back to top Go down
http://dennisbareis.com
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeSat Aug 15, 2009 3:22 am

MC is being developed on Vista64 and runs without issue. I also have UAC enabled and have not had any issues with it.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
esra
Junior Member
Junior Member


Posts : 45
Join date : 2009-05-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeMon Aug 24, 2009 7:44 am

OK, no idea why, but the new version works great.

I can't see the "Seasrch for new movies" button, but at least it's running!!
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeMon Aug 24, 2009 10:56 am

esra wrote:
OK, no idea why, but the new version works great.

I can't see the "Seasrch for new movies" button, but at least it's running!!

Glad you got it working, although I didn't intentionally fix the issue because I couldn't determine the cause.

The missing search button has been added to version 3.094 in the announcements forum

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: MSI Installer (using MAKEMSI)   Still getting error on new versions Icon_minitimeFri Nov 20, 2009 3:56 am

dbareis wrote:
billyad2000 wrote:
It is quite simple to allow MC to use the users application data folder for the files MC needs to function such as the config and cache file but some people want it to be portable, with all the files in a single folder.

This is one of the reasons that I want someone to create a deployment wizard for MC, it would allow this to be configured when installing.
Nobody has stepped up yet.

As per my previous post, I can do this using MAKEMSI (free tool, written by me) but I'd want pseudo code or some other description of what you'd want in the installer. It builds standard Microsoft Window Installer ".msi" files using simple script.

I'd probably want to start with simple installer without portable related questions (would someone even want an installer for that?). I don't know how MC decides certain things, for example where to put the config files, perhaps its as simple as if the "settings" dir exists use that else in profile, but I don't know all the rules...


Bye,
Dennis

P.S. I too want the app to be portable but its lack of relative filename support means, at least for my purpose, that I need a batch file to invoke MC as it needs to determine where it is and build full (absolute) filenames for the config files.


I've created a first cut of an msi that installs the files to program files, creates shortcuts for pgm, forum and readme and does some basic .net validation.

I do not understand why MC creates a "Settings" dir under the program files as I thought this was optional with the default going in user profile.

Anyway the build procedure is quite easy and mostly automatic (could be fully automated), on my machine the actual build takes less than a minute. I have zipped up the whole tree which includes the source files, source code as well as the generated output (the actual msi is at "out\Media Companion.MM\MSI").
Download the zip from here....

For the makemsi doco (compile help when installed locally) see: http://makemsi-manual.dennisbareis.com/quickstart.htm
Back to top Go down
http://dennisbareis.com
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeSun Nov 22, 2009 12:32 pm

I'll have a look at the MSI script, it may be that I end up having to do 2 releases, one for the installer and another that contains just the archived files as present.

Just wondering about a file called DtReg.exe, it is located in the MakeMSI folder and has been flagged as a virus by AVG.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeSun Nov 22, 2009 1:26 pm

billyad2000 wrote:
I'll have a look at the MSI script, it may be that I end up having to do 2 releases, one for the installer and another that contains just the archived files as present.

Just wondering about a file called DtReg.exe, it is located in the MakeMSI folder and has been flagged as a virus by AVG.

If you are paranoid you can remove it, either way its not a virus. The msi build could also build your rar file if you wished.
Back to top Go down
http://dennisbareis.com
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeSun Nov 22, 2009 2:12 pm

I didn't expect for a moment that it was a virus, I was just wondering if you've had any other reports that AVG was flagging it.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
dbareis
Senior Member
Senior Member
dbareis

Posts : 223
Join date : 2008-12-08

Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitimeMon Nov 23, 2009 9:37 am

billyad2000 wrote:
I was just wondering if you've had any other reports that AVG was flagging it.

These are the ones I know about: http://makemsi-manual.dennisbareis.com/possible_false_anti_virus_alerts_you_should_ignore.htm (DtReg.exe Flagged as "Dialer.IOS" by AVG8, or as "not-a-virus:RiskTool.Win32.Dtreq.a" by Kaspersky).

Its one of the rare commands that needs it so I may end up zipping it with a password and require users to unzip if they need it, the false AV reports are getting annoying.

Bye,
Dennis
Back to top Go down
http://dennisbareis.com
Sponsored content




Still getting error on new versions Empty
PostSubject: Re: Still getting error on new versions   Still getting error on new versions Icon_minitime

Back to top Go down
 
Still getting error on new versions
Back to top 
Page 1 of 1
 Similar topics
-
» 1073741819 error when playing TheHunter Primal

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Bug Discussion-
Jump to: