Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 Right TV show scrape, wrong episode scrape

View previous topic View next topic Go down 
AuthorMessage
nfugal
New User
New User


Posts : 5
Join date : 2009-12-14

PostSubject: Right TV show scrape, wrong episode scrape   Mon Dec 14, 2009 4:51 am

I've been using MC for a while now and so far things have been great. However, I recently ran into an issue.
When scraping episodes for Star Trek: Voyager, I get the episode info and thumbs from Star Trek (The Original Series).
I've checked TVDb and as far as the web side goes, it has the correct episode information, but for some reason scraping it pulls the wrong info.
Any good ideas how I might fix it?

Thanks in advance.
Back to top Go down
View user profile
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: Right TV show scrape, wrong episode scrape   Mon Dec 14, 2009 9:32 am

Examples would help Smile
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Right TV show scrape, wrong episode scrape   Mon Dec 14, 2009 4:21 pm

The only reason that would happen (assuming that the issue is not with TVDB), is if the tvshow.nfo file did not contain the correct tvdb id.

If this is the case then use the tvshow selector to select star trek voyager and rescrape it, then try rescraping the episodes again.

If this fails then I would appreciate it if you post me details of the show ID you are using, along with the series and episode numbers of some of the affected episodes.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
nfugal
New User
New User


Posts : 5
Join date : 2009-12-14

PostSubject: Re: Right TV show scrape, wrong episode scrape   Mon Dec 14, 2009 7:13 pm

I tried using the show selector and rescraping, and i checked the show ID in the tvshow.nfo file and it matches the ID on theTVDb.

Here's the first portion of the TVShow.nfo file

<tvshow>
<title>Star Trek: Voyager</title>
<year>1995-01-16</year>
<rating>8.6</rating>
<plot>Star Trek: Voyager, the third spin off in the Star Trek franchise, follows the adventures of the Federation starship Voyager, under the command of Captain Kathryn Janeway. Voyager is in pursuit of a rebel Maquis ship in a dangerous part of the galaxy when it is suddenly thrown thousands of light years away into the Delta Quadrant. With much of her crew dead, Captain Janeway is forced to join forces with the Maquis to find a way back home...</plot>
<runtime>45</runtime>
<mpaa>TV-PG</mpaa>
<genre>Action and Adventure / Drama / Science-Fiction</genre>
<premiered>1995-01-16</premiered>
<studio>UPN</studio>
<id>tt0112178</id>
<tvdbid>74550</tvdbid>
<sortorder>default</sortorder>
<language>en</language>
<episodeactorsource>tvdb</episodeactorsource>
<tvshowactorsource>tvdb</tvshowactorsource>

I only have the first season, but all 16 of it's episodes scrape as the original Star Trek. Here's a portion of the .nfo file of one of the affected episodes.

<multiepisodenfo>
<episodedetails>
<streamdetails>
<fileinfo>
<video>
<width>576</width>
<height>432</height>
<codec>XVID</codec>
<format>XVID</format>
<duration>1h 31mn</duration>
<width>859 Kbps</width>
<bitratemode>
</bitratemode>
<bitratemax>
</bitratemax>
<container>.avi</container>
<codecid>XVID</codecid>
<codecidinfo>
</codecidinfo>
<scantype>Progressive</scantype>
</video>
<audio>
<language>
</language>
<codec>AC-3</codec>
<channels>2</channels>
<bitrate>192 Kbps</bitrate>
</audio>
</fileinfo>
</streamdetails>
<title>The Man Trap</title>
<season>1</season>
<episode>1</episode>
<playcount>0</playcount>
<credits>George Clayton Johnson</credits>
<director>Marc Daniels</director>
<rating>7.3</rating>
<aired>1966-09-08</aired>
<plot>Kirk and his crew are at deadly risk from an alien creature that feeds on the salt in a human body and can take on any form.</plot>
<thumb>http://www.thetvdb.com/banners/episodes/77526/248304.jpg</thumb>
<runtime>91 min</runtime>
Back to top Go down
View user profile
paybac
Media Companion Supporter
Media Companion Supporter
avatar

Posts : 155
Join date : 2009-08-31
Location : New Zealand

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 1:29 am

I just tried this with sum dummy files and all scraped fine.

Try this.

Delete all .nfos and thumbs for each epsiode
Rebuild Tv Shows (should now have no episodes listed under Star Trek: Voyager
Right click on Star trek voyager left click "search for new episodes"
Back to top Go down
View user profile
nfugal
New User
New User


Posts : 5
Join date : 2009-12-14

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 2:47 am

I already tried a delete, rebuild, and rescrape twice and it's still pulling the wrong data. Any other suggestions?
Back to top Go down
View user profile
paybac
Media Companion Supporter
Media Companion Supporter
avatar

Posts : 155
Join date : 2009-08-31
Location : New Zealand

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 5:12 am

Ok, so you open up MC go to TV shows and it displays Star Trek Voyager? then you click on the season 1 and it display STV? then you click on Episode 1 and it displays Original Star trek episode 1?
Back to top Go down
View user profile
nfugal
New User
New User


Posts : 5
Join date : 2009-12-14

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 5:38 am

This is what it looks like

Back to top Go down
View user profile
paybac
Media Companion Supporter
Media Companion Supporter
avatar

Posts : 155
Join date : 2009-08-31
Location : New Zealand

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 5:43 am

try updating to 3.182. Man that is real weird tho
Back to top Go down
View user profile
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 11:28 am

*very* weird.

I've also just tested by creating a "Star Trek Voyager" folder in my TV Shows folder and some dummy files (s01e01.avi, s01e02.avi) and it scraped perfectly with 3.182.

<tvshow>
<title>Star Trek: Voyager</title>
<year>
</year>
etc...

<episodedetails>
<fileinfo>
<streamdetails>
<video>
<container>.avi</container>
</video>
</streamdetails>
</fileinfo>
<title>Caretaker (1)</title>
<season>1</season>
<episode>1</episode>
<aired>1995-01-16</aired>
<plot>Stardate: 48315.6
While in pursuit of a Maquis ship in a region of space known as the 'Badlands', Captain Kathryn Janeway and her crew aboard Voyager and the Maquis ship are transported 70,000 light years from home into the uncharted region of the galaxy known as the Delta Quadrant.</plot>


etc. etc.
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Right TV show scrape, wrong episode scrape   Tue Dec 15, 2009 2:17 pm

That is wierd,

Are you saying that it now works properly with build 3.182?

I am also curious about the TV Show list, that treeview is anchored to all sides, it should fill the left hand panel below the episode and show counter.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
paybac
Media Companion Supporter
Media Companion Supporter
avatar

Posts : 155
Join date : 2009-08-31
Location : New Zealand

PostSubject: Re: Right TV show scrape, wrong episode scrape   Wed Dec 16, 2009 1:10 am

billyad2000 wrote:

I am also curious about the TV Show list, that treeview is anchored to all sides, it should fill the left hand panel below the episode and show counter.

I think hes just blanked out his other shows with some white boxes Very Happy
Back to top Go down
View user profile
nfugal
New User
New User


Posts : 5
Join date : 2009-12-14

PostSubject: Re: Right TV show scrape, wrong episode scrape   Wed Dec 16, 2009 6:29 am

paybac is correct. I did blank out the other shows with some white boxes. And I just did a rescrape including a colon in the name (Star Trek: Voyager rather than Star Trek Voyager) using 3.182 and it worked. I'm not sure which change did it, but in any case it's fine now.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Right TV show scrape, wrong episode scrape   

Back to top Go down
 
Right TV show scrape, wrong episode scrape
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» How do I make the login popup show an Image, instead of it's bland colors
» New episode of My life as an HSP Podcast
» Design a Poster - 2011 Royal Hobart Show *australia only*
» Show Us Your Bum Photo Contest *usa only*
» Platt College Show and Tell Contest *usa only*

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: XBMC Media Companion Help And Useage-
Jump to: