Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 3.128 - multi-file runtime on initial scrape only picking up 1st file

View previous topic View next topic Go down 
AuthorMessage
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Tue Dec 22, 2009 2:34 am

Apologies if this has been fixed in a future build and I just can't remember it!

There still seems to be a problem when performing the initial Search for new Movies on scraping the runtime of multi-file movies. For me, it always only picks up the first file so I have to remember to go and batch re-scrape just to get run-time. Because batch rescrape does the entire collection this is really painful.

If it isn't already being fixed, I just wanted to keep it top of mind as it's about the only 'bug' I run into regularly in MC.
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Tue Dec 22, 2009 3:26 am

There will be another build before christmas, maybe tomorrow if I get time.

I've added support for multi part movie runtimes, the total runtime for all parts is now used.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Tue Dec 22, 2009 9:54 am

Awesome! Thanks Billy! Smile
Back to top Go down
View user profile
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sat Jan 02, 2010 5:42 am

I've just hit this again in 3.198 despite it being listed on the fixed list.

Fame (2009) CD1.avi
Fame (2009) CD2.avi

Runtime: 61min Sad
Runtime should be more like 107 mins
Back to top Go down
View user profile
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sat Apr 10, 2010 5:29 am

Still seeing this issue in 3.260

Avatar (2009) CD1.avi
Avatar (2009) CD2.avi
Avatar (2009) CD3.avi

Runtime: 58min

Runtime should be more like 162 min
Back to top Go down
View user profile
paybac
Media Companion Supporter
Media Companion Supporter
avatar

Posts : 155
Join date : 2009-08-31
Location : New Zealand

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sat Apr 10, 2010 5:53 am

Does it show the wrong time after a rebuild?

Also does rescraping or using batch rescrape return the wrong time as well on those movies?
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sat Apr 10, 2010 12:39 pm

To find out where the issue is try using the new 'Rescrape Specific' feature located in the movie list context menu.

On the main movie list Right Click on AVATAR.

Select 'Rescrape Specific'

Select 'Runtime'

Select either 'From File' or 'From IMDB'

'From File' returns the actual runtime of the movie files,
'From IMDB' scrapes the runtime from IMDB

Let me know if 'From File' does not work.

Also, when you double click the movie in the list, does it playback all 3 files, you don't have to watch the whole movie, just check the 'temp.m3u' file located within the MC Settings folder, when playing Avatar, does this file have the paths to all 3 files.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sat Apr 10, 2010 2:54 pm

'Rescrape Specific' -> 'Runtime' -> 'From File' returned the same wrong value
'Rescrape Specific' -> 'Runtime' -> 'From File' returns the correct value (and is what I'd used to fix it before posting this bug)

The temp.m3u only contained "\\antserver6\m$\Video\Movies\Avatar (2009) CD1.avi" so no, it is not pathing to all 3 files.

I just tried the same thing with a two .avi movie and am seeing the exact same results (just to confirm it's not because I happen to have a 3 file movie).
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sat Apr 10, 2010 6:35 pm

OK, i've found the issue, or more correctly issues.

Firstly, the media search MC was using was only looking for lower case extensions, eg cd2 would work, but CD2 would not.

Secondly, after fixing this it still was not working properly, it seems the new version of mediainfo MC was not returning any result using the old method.

I updated the media tags code and just tested with a 3 disk movie, and it works properly for all scraping modes.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   Sun Apr 11, 2010 9:33 am

Thanks Billy!!! Very Happy
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: 3.128 - multi-file runtime on initial scrape only picking up 1st file   

Back to top Go down
 
3.128 - multi-file runtime on initial scrape only picking up 1st file
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Sample UI Element file for google site.
» user-extensions.js file is needed
» Anybody any idea abt how to select upload file in webdriver
» Trusted File Seller Badge (TFSB)
» Create Batch file for Selenium

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Bug Discussion-
Jump to: