Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  SearchSearch  RegisterRegister  Log inLog in  

 

 [3.080] Possible bug with trailers

Go down 
AuthorMessage
J_K_M_A_N
Junior Member
Junior Member


Posts : 14
Join date : 2009-08-01

[3.080] Possible bug with trailers Empty
PostSubject: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitimeSat Aug 01, 2009 3:44 pm

I like to download trailers from Apple if they are available and I noticed that it is not seeing those. For instance, I have Yes Man and it has an AVI: Yes Man.avi and a trailer file: Yes Man-trailer.mov but it doesn't see that trailer file. When I open Media Companion and click on that movie it has the download trailer button.

I tried this when adding Obsessed also. I had the trailer file in there when I searched for new movies. It found the movie fine but it has the download trailer button again. If I click that and download the trailer, then it says play trailer but it plays the one it downloaded. If I download the trailer and then delete THAT trailer so there is only the .mov trailer, it will want to download it again.

Not sure if it just doesn't look for .mov trailers or what.

J_K_M_A_N
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

[3.080] Possible bug with trailers Empty
PostSubject: Re: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitimeSat Aug 01, 2009 10:03 pm

At the moment MC only sees trailers downloaded by MC, which are always flv files downloaded from IMDB, MC will see correctly named flv files from other sources.

Browsing was slowed down especially for people with network servers when checking for multiple types of media files.

I am not sure where I am going with trailers or how I will ultimately handle them. It may be that I will add support for all media types and have an option to disable them.

I will have to have a think about it.

Any suggestions would be valued.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion https://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
J_K_M_A_N
Junior Member
Junior Member


Posts : 14
Join date : 2009-08-01

[3.080] Possible bug with trailers Empty
PostSubject: Re: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitimeSun Aug 02, 2009 2:41 am

Maybe just a check when you click on the movie itself? Or is that where it is slow? I could see where it would be really slow if you keep all your movies in one directory.

It is not a big deal to me really. I really only use them in XBMC so as long as that finds them... Just pointing it out just in case.

J_K_M_A_N
Back to top Go down
user321
New User
New User


Posts : 1
Join date : 2009-08-04

[3.080] Possible bug with trailers Empty
PostSubject: Re: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitimeTue Aug 04, 2009 8:45 pm

I've come across what seems to be a bug in 3.080.

I clicked 'Download Trailer' for a movie and it downloaded fine. I then clicked 'Play Trailer' and VLC launched, saying it was playing a file called "movies-trailer.flv".

When I browse to any other movie within Media Companion the 'Play trailer' option is visible (rather than 'Download Trailer'), and it plays the same "movies-trailer.flv" file regardless of the film selected. This continues to happen even after Media Companion is closed and reopened.

Aside from that I just have to say THANKS! Keep up the outstanding work Smile
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

[3.080] Possible bug with trailers Empty
PostSubject: Re: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitimeWed Aug 05, 2009 12:19 am

J_K_M_A_N wrote:
Maybe just a check when you click on the movie itself? Or is that where it is slow? I could see where it would be really slow if you keep all your movies in one directory.

It is not a big deal to me really. I really only use them in XBMC so as long as that finds them... Just pointing it out just in case.

J_K_M_A_N

The check is done on the loading of the movie info, and the problem only really occurs for network servers such as NAS.
Even over NAS it takes no time at all to download an nfo (MC already knows the filenames) and even though it has several posibilities for fanart and folder naming it is still fairly instant.

The problem with trailers is that MC not only has several possible naming conventions, but dozens of possible file extensions. One person complained that the trailer seek extended the time to load a movie into the browser from less than a seconds to over 4 seconds, this is reduced when a trailer exists since the obvious extensions are checked first but if not then checking all posibilities takes time.

This is also a problem with playing back a file or getting file details, but since it only occurs when that specific option is selected then it doesnt really effect the overall slyckness of MC

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion https://billyad2000.darkbb.com/announcements-f1/


Last edited by billyad2000 on Wed Aug 05, 2009 12:23 am; edited 1 time in total
Back to top Go down
http://billyad2000.co.uk
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

[3.080] Possible bug with trailers Empty
PostSubject: Re: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitimeWed Aug 05, 2009 12:20 am

user321 wrote:
I've come across what seems to be a bug in 3.080.

I clicked 'Download Trailer' for a movie and it downloaded fine. I then clicked 'Play Trailer' and VLC launched, saying it was playing a file called "movies-trailer.flv".

When I browse to any other movie within Media Companion the 'Play trailer' option is visible (rather than 'Download Trailer'), and it plays the same "movies-trailer.flv" file regardless of the film selected. This continues to happen even after Media Companion is closed and reopened.

Aside from that I just have to say THANKS! Keep up the outstanding work Smile

Looks like there was a bug that would not save the trailer as the correct filename, the result is that all movies in the same folder look at that file as the trailer.

It is fixed for the next build. I'll upload it in a bit.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion https://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
Sponsored content




[3.080] Possible bug with trailers Empty
PostSubject: Re: [3.080] Possible bug with trailers   [3.080] Possible bug with trailers Icon_minitime

Back to top Go down
 
[3.080] Possible bug with trailers
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Bug Discussion-
Jump to: