Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  

Share | 
 

 Can no longer scan for new movies after upgrading from 3.237 to 3.251

View previous topic View next topic Go down 
AuthorMessage
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Mar 30, 2010 9:46 am

As the title says, I've just upgraded my installation from 3.237 directly to 3.251 (missed the release version in between as I was overseas on business) and when I now scan for new movies, it finds no new movies despite the fact I've added new content.

TV Show scanning is still working perfectly.
My Movies and TV Shows live on the same network share (a Windows server, not a NAS or anything which has caused some people issues).
I get no errors, it simply doesn't find any new content, i.e. log says "0 New movies found in directory"

I've done a "Rebuild movies" and "Reload Movie cache" but still same result.

I've run Process Monitor against my movie share and can see MC scanning the contents just fine.

This has me really perplexed! Any ideas?
Back to top Go down
View user profile
StormyKnight
VIP
VIP


Posts : 556
Join date : 2008-10-08
Location : Australia

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Mar 30, 2010 10:42 am

I moved the nfo, tbn & fanart.jpg from one of my movies 'Australia (2008)', rebuilt the movies (which removes this movie from the list) & then performed a search for new movies.

My movie was found but I did get an error message.

System.NullReferenceException: Object reference not set to an instance of an object.
at Media_Companion.Form1.appyfilters()


I press OK but the movie is not shown however the nfo, tbn & fanart.jpg have been created so a rebuild of the movies did fix it.

Is this similar to your observed behavior Anthony?



On a side note Billy, this has reminded me to ask if you could fix a cosmetic issue.

When scraping Movie Folders, the status bar shows to start with scanning folder 0 of 3...it seems as though it then processes the 1st folder & then changes the display to 1 of 3. I understand that it is displaying the folders completed, but it never will show 3 of 3 (very briefly) would it be better to show the folder its actually currently working on.. i.e.

scanning folder 1 of 3
scanning folder 2 of 3
scanning folder 3 of 3

Cheers
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Mar 30, 2010 1:47 pm

AnthonyB wrote:
As the title says, I've just upgraded my installation from 3.237 directly to 3.251 (missed the release version in between as I was overseas on business) and when I now scan for new movies, it finds no new movies despite the fact I've added new content.
Could you let me know the full path and filename of an affected movie.

StormyKnight wrote:
I moved the nfo, tbn & fanart.jpg from one of my movies 'Australia (2008)', rebuilt the movies (which removes this movie from the list) & then performed a search for new movies.

My movie was found but I did get an error message.

System.NullReferenceException: Object reference not set to an instance of an object.
at Media_Companion.Form1.appyfilters()
Could I ask what sort and list options you have selected.

StormyKnight wrote:
On a side note Billy, this has reminded me to ask if you could fix a cosmetic issue.

When scraping Movie Folders, the status bar shows to start with scanning folder 0 of 3...it seems as though it then processes the 1st folder & then changes the display to 1 of 3. I understand that it is displaying the folders completed, but it never will show 3 of 3 (very briefly) would it be better to show the folder its actually currently working on.. i.e.

scanning folder 1 of 3
scanning folder 2 of 3
scanning folder 3 of 3

Cheers
I'll change this for the next build.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Mar 30, 2010 1:56 pm

billyad2000 wrote:
StormyKnight wrote:
I moved the nfo, tbn & fanart.jpg from one of my movies 'Australia (2008)', rebuilt the movies (which removes this movie from the list) & then performed a search for new movies.

My movie was found but I did get an error message.

System.NullReferenceException: Object reference not set to an instance of an object.
at Media_Companion.Form1.appyfilters()
Could I ask what sort and list options you have selected.

I've duplicated this issue, it occurs when movies are listed using the 'Sort Order' method.

I'll fix it for the next build.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Mar 30, 2010 3:28 pm

StormyKnight wrote:
I moved the nfo, tbn & fanart.jpg from one of my movies 'Australia (2008)', rebuilt the movies (which removes this movie from the list) & then performed a search for new movies.

My movie was found but I did get an error message.

System.NullReferenceException: Object reference not set to an instance of an object.
at Media_Companion.Form1.appyfilters()


I press OK but the movie is not shown however the nfo, tbn & fanart.jpg have been created so a rebuild of the movies did fix it.

Is this similar to your observed behavior Anthony?

OK, repeated those same steps with a movie that was already in MC, saw it remove the movie from the list, but again it found no new movies when I did a search for new movies.

Whether another side effect of the upgrade, or due to the above testing, I now seem to have random mixup of posters and fan art on some of my movies :S

billyad2000 wrote:
Could you let me know the full path and filename of an affected movie.

"\\antserver4\d$\Videos\Movies\Edge of Darkness (2010).avi"

as mentioned, TV Shows which is working fine are in a similar path, e.g. \\antserver4\d$\Videos\TV Shows\Caprica
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Mar 30, 2010 4:33 pm

Nothing has changed between the builds that would cause this, the only change that I made was to allow MC to ignore multi part movie files with more than 4 parts.

I have tested this on my system and everything worked properly.

I usually use a mapped drive for my NAS, but for the test I removed the path and added the network path, here is a copy of my log.

Code:
Starting Folder Scan

found\\GIGANAS\public\Movies\Test
Checking for subfolders
Subfolder added :- \\GIGANAS\public\Movies\Test\d$
0 New movies found in directory:- \\GIGANAS\public\Movies\Test

1 New movies found in directory:- \\GIGANAS\public\Movies\Test\d$



1 Movies found in all folders
Obtaining Title for each movie found, from path and filename


Filename is: \\GIGANAS\public\Movies\Test\d$\Edge of Darkness (2010).avi
Title according to settings is: "Edge of Darkness"


Starting Main Scraper Process

Scraping Title:- Edge of Darkness (2010)
Output filename:- \\GIGANAS\public\Movies\Test\d$\Edge of Darkness (2010).nfo
Poster Path:- \\GIGANAS\public\Movies\Test\d$\Edge of Darkness (2010).tbn
Fanart Path:- \\GIGANAS\public\Movies\Test\d$\Edge of Darkness (2010)-fanart.jpg
NFO does not exist
Checking filename for IMDB ID
No IMDB ID found
Checking for Movie year in filename
Year found for movie:- 2010
Cleaned Title for search :- Edge of Darkness
Movie Body Scraped OKActors scraped OKPoster scraped and saved OK
Saving Fanart As :- \\GIGANAS\public\Movies\Test\d$\Edge of Darkness (2010)-fanart.jpg
Fanart not resized
Movie added to list

As you can see from the log it worked properly.

I was wondering if MC is finding all the subfolders, is your log listing all the subfolders, including the one that contains the movie?

Have you tried rolling back a build, I suspect that whatever the issue is, it may only be a coincidence that it occured for the latest build.
Check that the access rights have not changed, and that any passwords have not expired.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Wed Mar 31, 2010 11:20 am

So I've grabbed 3.237 and 3.244 and dropped them in fresh directories and pointed them to the same movies folder and I'm seeing the same issue.
Oddly, it will build up the moviecache.xml to the same point as my main MC install, but still search for new movies comes back with 0 items found.

It can't be permissions related as it would manifest in errors in building the cache on these new installs.
It's not the account or anything as nothing has changed and TV Shows are still working fine and scraping new TV Show content.

The point I made in an earlier post about posters getting randomly screwed up is also manifesting in all these clean installs. I've checked the physical files on the movies directory and they are all fine, however random movies are all getting the same poster ('The Road' which just happens to be the last movie successfully added).

There isn't some weird movie limit or other capacity limit I could be hitting is there? I've only got 594 movies in my list...

In answer to the question about subfolders, yes, MC is finding all subfolders.

In comparing the .nfo files being produced, I've also just noticed that MC 3.251 doesn't seem to be honouring the 'Save actor Thumbs' XBMC Path and is instead writing the path back out to IMDB.

None of this makes any sense to me - it's as though MC has just gone absolutely haywire?!?!
Back to top Go down
View user profile
billyad2000
Admin
avatar

Posts : 1326
Join date : 2008-09-20

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Wed Mar 31, 2010 11:45 am

Movies are stored in a generic array which has no practical limit, I believe the maximum is 2,147,483,647, and I doubt there are that many movies in existence.

I do seem to remember reading about some NAS servers that have a maximum number of requests or something similar that causes people issues, but I can't find the post.

I'll keep investigating though.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
View user profile http://billyad2000.co.uk
AnthonyB
Senior Member
Senior Member


Posts : 122
Join date : 2008-11-08
Location : Sydney, Australia

PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   Tue Apr 06, 2010 2:28 pm

OK, solved some of my issues. I was seeing a lot of what I considered 'random' wrong fanart or posters being displayed. Seems that somehow some very obscure settings got turned on, e.g. the create folder.jpg, fanart.tbn, movie.tbn, etc. Definitely not options I enabled so no idea how they ended up on.

I had been due to migrate my collection to a new server to retire my dear old HP NetServer E60 PII-450 that has been slowly deafening me so I accelerated this and will see how things fare once I've done some housekeeping on my collection.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Can no longer scan for new movies after upgrading from 3.237 to 3.251   

Back to top Go down
 
Can no longer scan for new movies after upgrading from 3.237 to 3.251
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Legitimate site for free tv and movies online--thousands of listings
» Great movies for HSPs to watch
» Hnov Luag Sib Tua Tsis Txhob Khiav Mus Xyuas
» Dab Nrhiav Niam Txiv , Movie Thaib, zoo li zoo thiab.
» Javascript Array

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: XBMC Media Companion Help And Useage-
Jump to: