Media Companion

Discussion and development board for the program Media Companion.
 
HomeHome  SearchSearch  RegisterRegister  Log inLog in  

 

 Can't add new movies.....

Go down 
AuthorMessage
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 5:00 am

Lately, when I add a new movie to one of my "watched folder" paths, MC isn't finding it when it searches for new media.

Thinking maybe it was an IMBD thing, I grabbed the latest version of MC from the announcements forum, and it's doing the same thing. The last movie it successfully added was from last tuesday.

I haven't done anyting differently. Just added the movies to the same folder as normal.

I'm stumped and annoyed.
Any help is appreciated.
Back to top Go down
punkjumper
Junior Member
Junior Member


Posts : 10
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 6:30 am

I'm having the same problem I think. Mine says it found the new movies but then doesn't do anything. the log says found 5 new movies then shows the IMDB # of the first movie on the list and then stops. no scraping happens. I have been using version 1.9... for a long time and that version would error and then close when I tried to scrape. I updated to the current version and it won't scrape.
Back to top Go down
punkjumper
Junior Member
Junior Member


Posts : 10
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 6:34 am

Back to top Go down
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 8:15 am

I guess I assumed it was a different issue seeing as how the person made that thread on the 25th, and a new version of the software came out on the 30th, and the issue I'm having is still evident in the new version.

Also, I'm not getting the errors listed in the thread posted.
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 12:05 pm

Could you give me an example of a movie, including path and filename when this happens.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 4:21 pm

This is the list of shared paths.
Can't add new movies..... Pbucket

Here is shows the last movies that were added to the MC list.
Can't add new movies..... Pbucket

This is the "Movies 7" folder on the server. As you can see, there have been multiple additions since "The Code" was added. And it doesn't find them when searching.
Can't add new movies..... Pbucket
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 5:47 pm

can you let me know a filename of one of those movies that is not added,

The sort by date is not working properly yet, is it not possible that the movies have been added, just not to the top of the list.

Have nfo files been created for the movies?

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 7:04 pm

Child's Play
12 Rounds
Dr. No
Die Another Day
Etc. Pretty much all the ones listed newer than "The Code".

No. There are no nfo files being created.

When I first noticed this problem the only new movie was "Child's Play". When the media search completed, the scraper output listed the movie but it wasn't added to the movie list. And the scraper output didn't any of the other info listed. P.s. This was on the old version of MC.
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 11:27 pm

an you let me know a filename of one of those movies that is not added?

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 02, 2009 11:38 pm

Those are the movie names.
All my movies are ripped at 100% quality straight from DVD. So I suppose their structured like:



Code:

Movies 7
    Child's Play
          AUDIO_TS
          VIDEO_TS
              VIDEO_TS.BUP
              VIDEO_TS.IFO
              VTS_01_0.BUP
              VTS_01_0.IFO
              VTS_01_1.VOB
              VTS_01_2.VOB
              VTS_01_3.VOB
              VTS_01_4.VOB
              VTS_01_5.VOB
Back to top Go down
jennec
New User
New User


Posts : 1
Join date : 2009-07-04

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeWed Jul 08, 2009 12:03 am

I had the exact same problem. I have 454 movies folder when I upgraded to beta 3 (latest, at the time of posting), All located under m:\movie name\. It refused to see any of the new movies I added (15 in total). So I checked the "Problem filter" but this did not make a difference. I then removed all of the original nfo files, and rescanned all the folders. Now I am in a worse position than before. I now have 450 movies in MC, and 469 folder, each have movie files in them. Any ideas? I do not get any errors, and MC seems scrape the missing movies.
Back to top Go down
pHluid
New User
New User


Posts : 3
Join date : 2009-07-08

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeWed Jul 08, 2009 6:44 pm

Confirming this problem as well. Movies are detected as new every time I do a media search, but they never scrape any NFO, Thumb, or Fanart. Really annoying, because I have to wait for it to fail to scrape 30+ movies every time just to scrape one or two new ones.

All movies scrape perfectly within XBMC 9.04.1 running on an Xbox 1.3
Windows 7 RC1 x64, all updates
Media Companion v3.032

All movies in D:\My Videos\Movies

List of movies not detected:

Baby on Board (2009).avi
Balls Out Gary the Tennis Coach (2009).avi
Bundy An American Icon (2008).avi
City Rats (2009).avi
Die Fälscher (2007).avi
Dolan's Cadillac (2009).avi
Fist of the Warrior (2009).avi
Futurama - Bender's Game [2008].avi
Futurama Into the Wild Green Yonder (2009).avi
Hero Wanted (2008).avi
Journal of a Contract Killer (2008).avi
Kavkazskiy plennik (1996).avi
Know Thy Enemy (2009).avi
Låt den rätte komma in (2008).avi
Lik Wong (1991).avi
Meet the Feebles (1989).avi
Meu Nome Não É Johnny (2008) CD1.avi
Meu Nome Não É Johnny (2008) CD2.avi
My Sassy Girl (2008).avi
Nobody Knows Anything! (2003).avi
Player 5150 (2008).avi
Rigged (2008).avi
Rise of the Scarecrows (2009) (V).avi
Stripper Academy (2007).avi
The Ramen Girl (2008).avi
The Steam Experiment (2009).avi
The Terrorist Next Door (2008).avi
XIII (2008) CD1.avi
XIII (2008) CD2.avi

I know posting the full list might be excessive, but I'm thinking maybe you can identify a pattern in these from the IMDB scrapes that might be causing the problem.
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 09, 2009 1:27 am

Thanks for everybodys input, this has been driving me up the wall all week, mainly because I was unable to duplicate it. I deleted all my nfo files and art and rescanned 1400 movies without issue.

This is caused by an error within the IMPA scraper, as a temporary workaround you should disable the option to add IMPA posters urls to the nfo file. Its located in the main movie scraper settings tab, in the "nfo poster options" panel, uncheck "IMPA".

The poster browser is not affected by this error, so you can still download thumbs from IMPA.

This should be easy to fix now that I know the problem, there will be a new build in the next day or two.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
pHluid
New User
New User


Posts : 3
Join date : 2009-07-08

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 09, 2009 2:26 am

Woot! Sure enough, that seems to have fixed it. Movies are now adding in properly and I'm seeing NFO, Fanart, and Thumbs added as I type.
Back to top Go down
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 09, 2009 4:16 pm

Maybe I have something set incorrectly.

Using Windows 7 64bit.
XBMC for Xbox (latest version)

Here are my settings.
Can't add new movies..... Pbucket
Can't add new movies..... Pbucket
Can't add new movies..... Pbucket

Also, after downloading the latest Media Companion (July 6th version), I now have most of my movies doubled up in the database. When I first loaded the latest MC, I hit the "rebuild movies" button to bring them up. Maybe I shouldn't have done that?

Can't add new movies..... Pbucket
Back to top Go down
pHluid
New User
New User


Posts : 3
Join date : 2009-07-08

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 09, 2009 4:44 pm

Your settings look identical to mine, with the exception that I also move IMPA to the bottom of the "Movie Scraper Thumbnail Priorities" list. I wouldn't think that would matter though, since it's disabled entirely under nfo Poster Options.

I did not do a Rebuild (and have not since it started working fine; if I remember when I get home I'll try doing a Rebuild and see if I get the same result as you)

The only difference I can see is that all my movies are ripped and encoded to AVI or MKV, all dumped in one folder. You're using separate DVD folders with "Create folder.jpg for each folder" and have "Don't overwrite existing thumbnails and art" checked. Is it possible since overwrite is disabled, it rescraped duplicate artwork etc and now thinks there's two copies of the movie in each folder?

Also, have you tried unchecking Disable Caching of Media DB under general settings to see if that makes any difference?
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Jul 09, 2009 6:04 pm

@00g

If a bug you experience has not been reported then please use a new thread for each different bug.

With IMPA disabled do you still have a problem scraping movies?

As for the duplicates, do the entries have the same path & filename, check the path textbox on the main page.

If you cant find a solution it then please start a new thread since I consider this bug fixed.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeFri Jul 10, 2009 1:31 am

Oh. I seriously doubt the duplicate movies issue I'm having is a bug. I just assume I clicked a wrong button. I was just bringing that up. I'll figure that out on my own.

And no, I still get no results when I initiate a "media search".

(Even with the settings as I posted in my screen shots (with IMPA disabled).
Back to top Go down
00g
Junior Member
Junior Member


Posts : 11
Join date : 2009-07-02

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeFri Jul 10, 2009 2:12 am

Ok. This seems to only be an issue with folders located on another computer.

I've moved a few movies to my desktop, and added the folder to the Media Companion folder list, and it found the movies with no problem.

Figure this info may help fix the issue.
Back to top Go down
stryk3r
Junior Member
Junior Member


Posts : 12
Join date : 2009-04-15

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeFri Jul 17, 2009 6:57 pm

I had the duplicate movies issue as well, I deleted all my nfo's and rescanned. I had 129 folders with 129 movies and it told me it was adding 256 movies......

I let it go and watched it and as soon as it got to 130, it started created the dupes again... I checked the folder and it was only creating 1 nfo file but I had .info files as well and thought maybe it was picking those up, so I cut the info file out of the first folder and I end task'd on MC, then relaunched it and rebuilt movies and it fixed all the dupes and found the correct number of folder.
Back to top Go down
billyad2000
Admin
billyad2000

Posts : 1326
Join date : 2008-09-20

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeTue Jul 21, 2009 11:57 am

OK - i've managed to create the duplicate movie issue and it will be fixed for next build.

_________________
Do you have a problem with Media Companion, before posting a bug then please check you have the very latest version of Media Companion http://billyad2000.darkbb.com/announcements-f1/
Back to top Go down
http://billyad2000.co.uk
chrisism
New User
New User


Posts : 2
Join date : 2009-08-06

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeThu Aug 06, 2009 6:05 pm

Its still not working here.
I am having this problem since the 2.x version, so for months now.
I tried most of the new 3.x versions. Still won't do it.

I even moved the app to my server to run it there, so it could scan local folders/drives.
Still it won't add new movies.

Is there any log option?
Did you use Trace methods for logging? So I could setup a .config file with trace settings.
I could have a better look why.
Back to top Go down
chrisism
New User
New User


Posts : 2
Join date : 2009-08-06

Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitimeFri Aug 07, 2009 3:03 pm

Alright.. I have a sort-of solution.
Used the old 2.292 version to scan the folders and create the nfo files.
Used the new gen version to update the newly scanned items.

So, to help you.. compare the scan from 2.292 with the code from the new version.
Something has changed here resulting in the scan problems.
Back to top Go down
Sponsored content




Can't add new movies..... Empty
PostSubject: Re: Can't add new movies.....   Can't add new movies..... Icon_minitime

Back to top Go down
 
Can't add new movies.....
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Media Companion :: Media Companion :: Bug Discussion-
Jump to: